Hello & Welcome to our community. Is this your first visit? Register

User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Junior Member
    Bike
    MT-09 2017
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    New 2017 MT-09 Engine problem?

    Hi everyone,

    Just looking for a second opinion from any mechanical types here as I think there's something wrong with my new 2017 MT-09 AU model with Akrapovic Titanium exhaust (fitted by the dealer).
    From day one I've noticed the engine is quite rough\hesitant when not fully on the gas. It's not easy to describe but here goes.
    It's evident when trying to maintain a constant speed or in gentle acceleration, mostly noticeable between say 20-80 km\h in the relevant gears. It kind of surges\hesitates holding a speed like in roundabouts and start\stop traffic.
    As soon as you accelerate hard it smooths out, and it goes like the clappers so it's hard to complain.
    When riding steady though it feels like the engine is misfiring or the revs are oscillating.
    In fact standing still in neutral, if I hold the throttle at around 3000rpm I can hear the engine oscillating and see the tacho jumping up and down 1-2 ticks.
    In day to day traffic it can be really annoying. Yes, I know someone will suggest to just ride it flat out all the time but with a bike like this I would be in jail by sundown.

    Now, I've never ridden a triple before, only owned motard\trail bikes but I'm pretty sure this can't be normal behavior?. I don't remember my demo ride being like this.

    When getting the 1000km service I explained all this to the dealer. I thought it might be the air\fuel mix related to the exhaust but they said they checked it. (Such a shame we can't adjust it ourselves now)
    Then when I took it in for the handlebar recall, I asked them to check it again. They said they did adjust it but after that I couldn't tell any difference.
    Now they say I will need to get a Dyno tune-up done that will cost me $700. Is that the normal price?
    I just feel this shouldn't be necessary so soon on a new bike. I think it has about 2000kms on the clock now.

    What do you think? Anyone else noticed this sort of thing or have a suggestion?

    Cheers

  2. #2
    Junior Member
    Bike
    MT09 TRACER
    Join Date
    Jun 2017
    Location
    GB
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Maybe ignition problem ? Spark plug or coil ? There's many people here with more knowledge than me .

    Sent from my SM-A520F using Tapatalk

  3. #3
    Member bumpyride's Avatar
    Bike
    2016 MT09 race blue
    Join Date
    Jan 2017
    Location
    Australia
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    HI if you read the ECU flash threads you will see we all have the same problem. Know were not in the EU but its to do with air/fuel mix for emissions. I have mine booked in end june for a full woolich racing dyno tune the guys will sort it out, and yes its $700 bucks. i dont ride mine to work for the reason of the surging i hate riding it slow. my husbands S1000r does the same thing. price we pay to save the planet and continue riding. Read the thread you may find a cheaper option. im also geting a K&N air filter put on but im not interested in the Akro. hope this helps in some way,

  4. #4
    Member donut's Avatar
    Bike
    MT-09 & MT-07 and CB200
    Join Date
    Aug 2015
    Location
    Berkshire, UK
    Posts
    81
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by MT-09Black View Post
    Hi everyone,


    It's evident when trying to maintain a constant speed or in gentle acceleration, mostly noticeable between say 20-80 km\h in the relevant gears. It kind of surges\hesitates holding a speed like in roundabouts and start\stop traffic.


    Cheers
    This is something that my (15 model year) MT did and I believe is/was quite common.

    Most of it was cured when I fitted one of Kev's O2 optimiser thingies which has now been super-ceded by a reflash by Simon.

    I thought this had been cured on later model bikes though.

  5. #5
    Junior Member
    Join Date
    Apr 2014
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The Mt-09 has 3 problems.
    1. The mixture is set lean to meet emission standards.
    2. Engine brake is excessive. This can be fixed with an ECU flash.
    3. Throttle bodies go out of sync within a few thousand kms. This can be fixed by setting them yourself. I use a carbtune device. Youtube videos show how to do it. Dealers will charge you lots and will stuff it up. Also adjusting screws are very sensitive so take your time. If your bike runs jerky and starts hesitating it is time to resync your throttle bodies.

    Sent from my GT-I9506 using Tapatalk

  6. #6
    Junior Member
    Bike
    MT-09 2017
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks to everyone for the replies. Very interesting info. I will have a read through the ECU Flash thread.
    It's good to know mine is not a lemon if it's a common issue. I guess the hard part will be finding someone locally with enough experience to sort it out.
    I guess we shouldn't feel too bad about the tune-up cost as it is probably the best bang-for-buck bike available right now.

  7. #7
    Junior Member
    Bike
    MT-09 2017
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Big Julie...
    1. So if it's too lean, does that mean it will use more fuel when fixed, or the opposite?
    2. I had noticed quite a drone sometimes amongst all the crackle and pop, but it hadn't worried me too much. I figured it was just a feature of the Akro.
    3. This is very interesting. I heard it was an electronic throttle, but not sure what you mean by out of sync? I'll check it out on YT.

    Cheers

  8. #8
    Junior Member
    Join Date
    Aug 2016
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by MT-09Black View Post
    Thanks Big Julie...
    1. So if it's too lean, does that mean it will use more fuel when fixed, or the opposite?
    2. I had noticed quite a drone sometimes amongst all the crackle and pop, but it hadn't worried me too much. I figured it was just a feature of the Akro.
    3. This is very interesting. I heard it was an electronic throttle, but not sure what you mean by out of sync? I'll check it out on YT.

    Cheers
    Regarding number 3, have a look here YouTube never done it, but looks easy enough. This bloke has just got his bike, and has done a shed load of YouTubes, all pretty good.

    Just watched his brake one, I thought my MT's brakes were crap, so for 35, I think I'll change the pads

  9. #9
    Senior Member MT09-Smurf's Avatar
    Bike
    MT09 ABS Deep Armour
    Join Date
    Jul 2014
    Location
    West Midlands
    Posts
    415
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by MT-09Black View Post
    I guess the hard part will be finding someone locally with enough experience to sort it out.
    The flash will sort it out... transforms the bike, Depending on where u are in Oz, try finding Kevin Hope (KevXTX)... He's ya man..
    Deep Armour- Puig Dark Tint FlyScreen - R&G Crash Bungs - R&G Rad Guard, Shortie Levers, Modded Akrapovic Titanium Can, Aftermarket ECU Flash, Evo-Tech Tail Tidy & LEDs, Ermax Seat Cowel (with tank stripe), HEL Carbon Brake Lines....

    Facebook: https://goo.gl/ZGboq6

  10. #10
    Junior Member
    Bike
    Yamaha mt 09
    Join Date
    Oct 2016
    Location
    Bridgend
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've got a 2016 MT09 and mine doesn't suffer with this I've got a standard exhaust, I must be lucky as I don't seem to have any issues at all, there's a very slight delay in twisting the throttle to the power coming on compared to a carb setup but that's it...

    Sent from my HTC U11 using Tapatalk

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -7. The time now is 06:58 PM.
Powered by vBulletin® Version 4.2.5
Copyright © 2017 vBulletin Solutions Inc. All rights reserved.
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like v3.2.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.


MT09.motorcycle-talk.com is not associated with Yamaha in any way. We are an enthusiast site dedicated to the Yamaha MT-09 / FZ-09 motorcycles. Our goal is to offer a place for Yamaha FZ09 / MT09 owners to discuss rides, events, mods, maintenance, purchasing, etc.

vBulletin Skin By: PurevB.com