ABS WARNING LIGHT


kev

Member
The ABS warning light sometimes comes on when I riding (2017 ABS MT09) as far as I can make out it means the system is turned off? I have to turn the ignition off and "reboot" it, I can do this while riding, don't know if I should stop to do this.
I don't know why the light comes on, I thought maybe the rear wheel was spinning up but the traction control light isn't coming on, well not that often. any ideas why this is happening,
 

deadb0y

Member
Mine did that a few times (16 MT09 Tracer).. I checked all the plugs for the sensors front and rear (unplugged, plugged back in a few times) and it cleared up!
 

kev

Member
Mine did that a few times (16 MT09 Tracer).. I checked all the plugs for the sensors front and rear (unplugged, plugged back in a few times) and it cleared up!
thanks, I'll give it a go. I did clean the rotors that helped a bit, might be a combination of a couple of things?
 

the cueball

Member
The ABS sensors have their own rings that they work from, these can get hovered in grime/rust and even dented with stones etc.

I would remove the actual sensors at the wheel (a Yamaha only job if you believe the manual) it’s really only a couple of bolts, clean the sensors and look at the condition of the ABS rings...

I’ve had to sand down and paint mine a couple of times now!
 

kev

Member
cleaned the rotors and sensors the rear looked ok, the front had a bit of dirt in sensor, had a ride to Seaways Cafe, 60 mile round trip, all ok, although was in B mode as roads wet and filthy but was good to get out on the bike.
 


Top