Temp light (hi temp problems)


bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
Hi everyone new here so hi

So let me explain a little recently bought a 2015 mt09 and i must say what a bike lol so been riding back and fourth work about 5 miles great .. well today went a little further Afield and while riding noticed red temp light came on with temp saying Hi temp so stopped fan was on and water coming out of over flow on expansion bottle well i let cool for half hour road home by time i got home did same exact thing all with in less than 20 miles. Temp just keeps climbing high ( even while sat there ticking over) till light comes on and water comes out will be contacting dealer i bought form on Tuesday ( not open monday ) but wondering if anyone could shed a bit of light ( no pun intended 😂)

Sorry for essay but its my first proper bike thanks in advance 👍👍
 

stevecbr

Member
Joined
Oct 13, 2013
Messages
978
Reaction score
7
Points
18
Location
Norwich, Norfolk, United Kingdom
Let us know how you get on, not a problem I am aware off. Is the oil clean or milky white?
Top of my head I would guess either failed water pump, blockage or failed head gasket.
I dont think an air lock would cause this (it may have had a coolant change at service before dealer sold it)
 

bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
Thanks for replying coolant is clean as so is oil if i squeeze pipe i can feel water pump sucking so thinking can rule that out the pipes get really hard almost as if its pressuring so im thinking head gasket dealer picking bike up tomorrow so will see what they say and let you know
 

bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
Not really went in to garage Wednesday had phone call yesterday they apparently say its the thermostat but ordered a replacement hopefully that will help 😂 their words so we see i will post update 👍
 

bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
Well just a little update had bit back they did thermostat and new rad cap drove 20 miles thought it was great regulated temps fine 20 miles back temps up and down light on again 🤦🤦 bike going back again stressful times lol lets see what bullshit they say it is this time 😂😂 but the bike seems to be able to keep temps better after this but 30 in moving traffic is where the problem show again 70-70 temps at between 99-111 sooo ill keep updates when i know more 👍👍
 

stevecbr

Member
Joined
Oct 13, 2013
Messages
978
Reaction score
7
Points
18
Location
Norwich, Norfolk, United Kingdom
Sorry to hear, at least the dealer looks like he will fix it. Do you get a loan bike when yours is in?
Usually when Im stuck in traffic, the temp can reach about 102 or 105, then the fan kicks in and it cools back to about 98 then the fan goes off.
Does the radiator look OK, some people attempt to clean them with a pressure washer and damage the fins, which stops the air from cooling the bike
 

Peeltheorange

New member
Joined
Oct 17, 2021
Messages
7
Reaction score
3
Points
3
Location
Sussex
Sorry to hear of your troubles, but does at least sound like a fault that your seller is trying to fix..

My mt09 (2014) one of the early ones, seems to run cool, usually shows 65 - 75 c unless its pushed hard, the place I notice the temp go higher is when youre stationary in traffic for more than 5-10mins (a rare event 4 me) then you should hear the cooling fan kick in... how quickly does yours get up to a stable temp from cold?, swapping the stat out is at least an easyish job as its external on the pipework, what sort of temp does the external rad pipe get up to when the temp goes high?, ild be interested to know what the typical coolant temp other people see on the lcd readout on their mt09's, anyone know where the temp sensor is located ?
 

bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
Sorry to hear, at least the dealer looks like he will fix it. Do you get a loan bike when yours is in?
Usually when Im stuck in traffic, the temp can reach about 102 or 105, then the fan kicks in and it cools back to about 98 then the fan goes off.
Does the radiator look OK, some people attempt to clean them with a pressure washer and damage the fins, which stops the air from cooling the bike
Yea they deffo seem to want to get to the root of the problem. This time ive got a loan bike 20 plate mt 07 better than nothing lol and the rad is completely new they changed that so assuming that is good
 

bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
Sorry to hear of your troubles, but does at least sound like a fault that your seller is trying to fix..

My mt09 (2014) one of the early ones, seems to run cool, usually shows 65 - 75 c unless its pushed hard, the place I notice the temp go higher is when youre stationary in traffic for more than 5-10mins (a rare event 4 me) then you should hear the cooling fan kick in... how quickly does yours get up to a stable temp from cold?, swapping the stat out is at least an easyish job as its external on the pipework, what sort of temp does the external rad pipe get up to when the temp goes high?, ild be interested to know what the typical coolant temp other people see on the lcd readout on their mt09's, anyone know where the temp sensor is located ?
So mine is a 2015 and it warms up really fast and running temps of over 80c all the time every ride the fan is on of i push it higher speeds the temp fluctuate but slow moving temp is 106 and above yea would be nice too know others temps 👍
 

stevecbr

Member
Joined
Oct 13, 2013
Messages
978
Reaction score
7
Points
18
Location
Norwich, Norfolk, United Kingdom
When riding about 70-80mph mine is steady at about 70 degrees C give or take couple of degrees. As long as I'm moving it will stay at this temperature indefinitely. Temp will creep up when at a standstill, but again drop to about 70 odd when moving. I have a radiator guard and side covers fitted, they dont appear to make it run hotter. Riding in the summer or winter also doesnt appear to make any difference, apart from it takes longer to reach 70 degrees
 

bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
When riding about 70-80mph mine is steady at about 70 degrees C give or take couple of degrees. As long as I'm moving it will stay at this temperature indefinitely. Temp will creep up when at a standstill, but again drop to about 70 odd when moving. I have a radiator guard and side covers fitted, they dont appear to make it run hotter. Riding in the summer or winter also doesnt appear to make any difference, apart from it takes longer to reach 70 degrees
See thats sounds rather normal compared to mine which is running 106 plus all the time never rode it (only rode 3-4 times 😂) where the temp is lower and not had the fan on its constantly on 😂 deffo sounds like a issue lol
 

Peeltheorange

New member
Joined
Oct 17, 2021
Messages
7
Reaction score
3
Points
3
Location
Sussex
Have been keeping an eye on my temp, today 75c , as steve says only time normally youll see it rise is sitting in still air high90s or over 100c, i wonder if yours has some head gasket type problem, on cars usually yould see loss of coolant (might be worth eyeballing the level in that little tank on rhs) on cars they use some test with a dye that changes colour when exhaust gas gets into the coolant) but i would imagine yould have some coolant loss, maybe its minimal..

I wonder if you could install the thermostat the wrong way round such that it didnt open, just a thought..post a pic of your stat (its on pipework in front of engine).. but maybe not if they have replaced it, although if working to the 'put it back as you found it' principle that would follow 😁
 

bonkeyez2

New member
Joined
Oct 1, 2022
Messages
8
Reaction score
0
Points
1
Location
Wales
The bike is currently at the dealer i bought it from for the second time which they told me not to worry as the mechanic is a 30y trained Yamaha mechanic i burst out laughing at that as it shouldn't of gone back a second time if that was the case. Ive checked both coolant my self and there no loss of coolant untill it bubbles out the expansion bottle ive said since the first time that its head gasket to which i get told ' naaa no chance of that its very rare ' but this time ive asked for the dye test to be done so hopefully some point this week ill have a update on the issue/issues so will let u guys know 👍👍
 


Top